Hello There, Guest! Register
Enjoy our site and services? You may donate to help fund server and domain costs. Donate Here for special benefits. You have donated $

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible dev unit?
So, I have 3 of these now. Funny story, but that's for later. It also led me here, which is awesome! I purchased one of these about a week ago, plugged it in, hooked it up. After it powered up (seemed normal because I've never used one before) it had the message "Use Controller FPO" and appeared to already have user names. Called Leap, they asked me if it had any errors, and I told them that it seemed fine, I just can't sync the controller and the screen says "Use controller FPO". They informed me that I was following the proper procedure, and that the unit needed to be replaced. He seemed to know what the problem was right after I read it to him. Unknowingly, my wife also called toys"r"us after I called Leap, and that's why we now have 3. After the new unit came, the start-up is completely different, and the controllers sync now. Anyone else ever seen this? I've looked all over google and can't find any information. I'll get some pics and a video of the start up to post. I'm also curious if the hardware may be different. Probably gonna open it up and compare to the other unit or the pics I found in this forum.  Board photos;  

[Image: 20160520_005426.jpg]
[Image: 20160520_005516.jpg]
Sounds interesting.

Funny story.. I have 3 also Smile

Bought one originally for a dev unit to mess with, and one for the kids to play on, although it hasn't been used that much.

Picked up another from the car boot sale a couple of weeks back for the price of £2.50 complete with with controller and camera (albeit the usb lead on the camera had been chopped).

When I plugged it in, it hadn't even been set up before and didnt have any profiles or anything...

Couldn't get a vid to upload to the post, but put it on youtube. This was an out of the box, new unit from toys"r"us. Ideas?

Not sure, could be a unit that's undergone some form of testing and they haven't reset it back to factory defaults?
Set development mode, and dump the file system? (if you use FTP make sure you tick the force BINARY transfer mode, as the built in ftp server on the LFTV seems to corrupt the files by send added linefeeds if you don't).

I'll give it a shot. Will post the results.
So, quick update. I do believe this is a test unit. I've attached some pics.

 It has a program called DynaBUG on it, appears to be a diagnostic tool set for dev's. Found some pics of it running in a support forum. Still working on getting access. Will update later.

One pic is a screenshot of dynaBUG showing up in the installed games list on the lpm on my unit.

Attached Files Thumbnail(s)
Anyone know how to connect to a bluetooth module through the terminal? I've used hcitool on ubuntu, but this is different. Trying to connect a bluetooth keyboard to the unit. I can shut down the ui from the terminal, so now I just need a way to control the system directly and then i wont have to telnet in.

(Edit) Been playing around in /usr/bin and I've been able to trigger some apps that overlay the gui. I'm pretty sure that if I can get some kind of native control that I could use this little thing as a full fledged (albeit tiny) linux desktop. If you run : /usr/bin/./assistant it opens a native linux app, and it appears to have xwindows characteristics.
That last picture looks to be debug testing stuff. I had something similar on my LeapPad Ultra. I ran one of them and it bricked the device. Be very cautious in there Smile
(05-20-2016, 11:22 PM)Deak Phreak Wrote: That last picture looks to be debug testing stuff.  I had something similar on my LeapPad Ultra.  I ran one of them and it bricked the device.  Be very cautious in there Smile

So.. As of yet I have bricked the unit, and brought it back to life. Unit no longer is recognized by LPM. 

I have made some progress on getting the unit to sync with otherwise bluetooth devices. I'm working with the connman pkg at the moment. Tried to import apt-get with wgrep but no avail. Would love to get bluez imported, then I would be able to manage the system without tunneling in. I did however notice it doesn't carry HID drivers, but has an exception for a keyboard. Hoping its bluetooth.
Still toying around in the /usr/bin ... Don't know why they put all the goodies there instead of /bin ...


Forum Jump: