Hello There, Guest! Register
Enjoy our site and services? You may donate to help fund server and domain costs. Donate Here for special benefits. You have donated $

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dodgy Touchscreen, failed RMS Test
I've got a LeapPad with an unresponsive touchscreen. Well, it does respond, but not always accurately and seems to interpret finger touches better than those from a stylus. I ran the MFG Tests and it consistently fails the RMS test despite calibrating it beforehand.
Is there anything I can do to fix it or is it purely a hardware fault? I haven't tried cleaning it thoroughly yet but I'm guessing that's not the cause!!
Thanks for any advice.
Did you take it completely out of the shell and ensure to clean any gunk that might be wedged between the case and screen? You ran the calibration test in the MFG Tools? Doing that usually gets me up and running with the replacement screens I use. I did code in some preset values so I didn't have to keep doing the calibration test every time. Not sure if those will show up in your menu or not though.

Forum Jump: