Hello There, Guest! Register
Enjoy our site and services? You may donate to help fund server and domain costs. Donate Here for special benefits. You have donated $

Someone has taken over the domain, so the site will continue!

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Full game downloaded from LL store doesn't show as bought.
I got myself a 3S to play around with from eBay, and the seller gave me her account details as it had a load of downloads on it already.
I have since linked another 2 3S to the account, and went to download some of the bits to them. It worked fine, but I can't get it to download a full game again that was already on the first tab. It says I need to pay for it again, even if it is to a new card in the original tab.
Spiffy hack picked up most of the other downloads, and I could decrypt them (but not sure what to do with them next), but this one will just not be done. it shows up fine on the original tab to play, but I can't transfer it, or do anything else with it.
It's Sophia the first, same as the cart version I believe. File named 58-126803-000-064.ita 115MB
Also, the decrypted games, do I need to encrypt them with the UnitEID from the tab they are to run on, or can I just use them as a folder somewhere and reference them in the innotab_wf database?
Any ideas?
I am unsure why that other one will not run on the second tablet. If it downloaded onto your first one, then you should be able to pull it off via the spiffy hack app and get it on there. I think they have a limit of how many devices can use the apps though which may be the issue you are running into.

To use the apps, you must flash a custom firmware and then edit your innotab_wf database and reference them to the paths on the SD card along with your UnitEID.
After our 90 mins of trying to recover my bricked tab in IRC a couple of weeks ago, I am pretty sure i have a modded firmware, hehe. It's running other things fine.
I would even have to pay for it again to download it onto the tab that already has it on, so I don't know what is going on there.

I have tried pointing the database towards the folders starting 58-xxxxx, then the folder within that, then the _run file directly, but non will work for some reason.
The Sophia game was already on the tab when i got it, but the person who had the tab before hadn't modded it in any way. So I am not sure how they got it on there. I will try moving it to a different folder to see if it is that the hack is just not picking it up where it is.
You should only have to point the database to the folder that contains the _Run file in it. I don't remember if you have to extract files any further or anything after it decrypts them. Also you have to make sure your correct UnitEid is added for each app in the database.
UnitEID is fine on all entries.

I have noticed that most of the apps/games extracted with SpiffyHack have got a dlg.squashfs.bin file in the folder. A couple that I have located on the net (for comparison and learning purposes only, of course Wink ) do not have this file. I am guessing that the needed files are still hidden away safely in there? What can I use to extract them? I understand it is a compressed linux file system thing, but I don't have a Linux box running.
I have had a look at one of the the files with Hexedit, and the following is at the end, I am guessing it is a file list.

game124.pkg ¤

I've still had no luck extracting Sophia either. It is located in the
Drive letter:\LLN\APPS\Games folder.

Does Spiffy hack look there? If not, where should I try to move it to? Or how to extract it manually?

The other games that it does find can't be seen on any of the partitions in Windows. Although there is one drive that shows up as being 31.7 MB, with 0MB free. But nothing shows when I open it.

So the innotab makes 3 drives.
Removable Disk - FAT - the 31MB one.
IFSD - FAT32 - Internal memory? Has an LLN Folder.
Removable Disk - FAT32 - The Micro SD memory card.

If necessary, I will hook it up to the USB-TTL doodad and try browsing it that way.
All your apps should be in your Micro SD card. I have tried putting stuff on the IFSD which is the internal memory and it doesn't work. I recall after decrypting the installed apps, needing to delete a bunch of stuff or extract a compressed file to get the actual game files. I believe by default it has a _Run but also has a _Run in another folder or something and that is the folder I used and just deleted everything else. Been too long since i've messed with it.

Unsure about the Sophia one. If it was from a cart, it should be in a .bin file and you should just have to point directly at it in the database. I can't remember where the spiffy hacks looks for the apps lol. Been too long since I made it. You can always look at the code in an editor, it is all there. You don't extract .bin files from carts, you just run them as .bin files from the SD.
I managed to extract on of the dlg.squashfs.bin files by removing the .bin and running it through extract now, so i am going to try that in a sec. The extracted files include a _Run file.

I know Sophia is the same as the cart, but a downloaded from the store version. It would be much easier if I could "find" it somewhere. Most "research" links seem to be dead now (or for French versions of games).

The extracted Squashfs files work fine. Now just to sort out that flipping Sophia (and all the icons for the others).
ok that must have been what it was then, after decrypting the game, you extract that bin file to use on the SD card. I knew there was an extra step in there somewhere to get them running on the SD card.

I am not sure about the Sophia one. I don't have that one. If spiffy hack isn't finding it, then you could always modify the script to search the location it is in as well or manually run it on the file.

I opened my script and it looks in this location for the files /vp_mnt/if_dlg/LLN/APPS/Games/*.ita so I am not sure if that is the same spot as your Sophia game, but most likely not. We would need to find out where that location is mounted to.
Yeah, all the extracted ones work fine now.

IFSD:\LLN\APPS\Games\58-126803-000-064.ita is the location of Sophia in windows. Is that the same when mounted? I will re-solder the tx-rx spots in a bit to take a look if not.
That is the windows path, it will be something different in linux. /vp_mnt/sd/ is the SD card. You could copy the .ita file to your SD card in a folder and then modify my spiffy hack script in the decryptgames function and change the path from /vp_mnt/if_dlg/LLN/APPS/Games/ to /vp_mnt/sd/sopphia/ or whatever. It should then find it and decrypt it, then stick it in the decrypted games folder. Just make sure you change all references to the old path to your sd card instead.

Forum Jump: