Hello There, Guest! Register
Enjoy our site and services? You may donate to help fund server and domain costs. Donate Here for special benefits. You have donated $

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Australian model, 42.31122 firmware
#1
Hi team,

I was hoping someone could help with patching my firmware or point me to one compatible with my console. I just bought this unit in Australia for my son's 5th birthday. I have logged onto the learning lodge and tried to update and it says up to date with firmware 42.31122. I grabbed a music file and got my UnitEID and dumped my firmware. The file is below, i tried to download after uploading and it seems fine. I was going to risk the 42.31121 file from the download section but am afraid the difference may brick a day old console. Any help would be greatly appreciated.

https://www.sendspace.com/file/rt4ovj
Reply
#2
It most likely won't flash if you tried it since it checks a signature date on the device. I am not sure when I will have things up and running on my computer for firmware patching... see ( http://spiffyhacks.com/thread-221.html ). Be sure your SD card is solid and does not have any issues with random disconnects or anything before attempting any flashing or you could brick the device!
Reply
#3
Thanks for your response, but enjoy your vacation, i can wait.....

I have managed to get the uk version 42.31128 working on my system although i have a few minor bugs like the pixel issue, a few have mentioned before. Most things like my personal cart backups, flash games work fine. Playing with icons now.

I was attempting to do my own cfw with the tutorial you have but between my distro of backtrack and Ubuntu i can't seem to get the courage to follow through as the sizes and md5 checks are all over the place when i unsquash/mksquash.

I'm a noob to this so bare with me but my plan was to unsquashfs one of your fw's, unsquashfs my original, compare to figure out where to make changes and then mksquashfs my original. Before going a head i "assumed" that if i un and mk one of your firmwares or my original it would return checks positive but they were different so i backed of. You firmware atleast matches in size after a un/mk, but mine looses around 5 meg and mk's at the exact same size as your firmwares?

Anyway i got one of yours working on my system, so the kids are content regardless of pixel issue etc. I can only assume as i didn't expect it to work that the date stamp is to stop downgrading?

Enjoy your holiday mate......

By the way Deak, it's more than likely my end, but the link above along with many i've found in the pages here give me 404 errors...........
Reply
#4
(07-06-2014, 10:32 PM)tivanh Wrote: .

By the way Deak, it's more than likely my end, but the link above along with many i've found in the pages here give me 404 errors...........

It's the hyperlink formatting.
The links takes you to:

http://spiffyhacks.com/thread-221.html).

Try this instead:

http://spiffyhacks.com/thread-221.html
Reply
#5
Yea sorry about that, the auto URL thing messed it up so I fixed it. Glad you got a firmware working. They may not adjust the date stamp on the firmware if they are just increasing the version by 1. Sounds like you are on the right track of doing your own firmware customizing. When going from an original dump, patching the firmware and then squashing it again will decrease the size. As long as the final modified firmware size matches close to ours then you should be fine.

Did you find what to edit to patch the firmware? I believe it started as 1 file, then we had to edit 2 files to get around a change they made, then I think it was merged back into 1 single file. You basically need to remove the SD card checks so the files can be run from the SD card, then add the code that unmounts and remounts the SD card as executable.
Reply


Forum Jump: