Hello There, Guest! Register
Enjoy our site and services? You may donate to help fund server and domain costs. Donate Here for special benefits. You have donated $

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Storio2 DE v44.30321
#11
I wonder if something is causing the SD card to not be remounted with noexec.

Can you turn on the tablet, try to run a flash game and then when it kicks back to the menu, choose the backup firmware option again and post the mounts.txt file.

Be sure to remove your old backup and mounts.txt from your SD card. It is supposed to remount the SD card when you try to run an app.

Edit: also try removing the SD card, re-inserting etc. Have it out... boot up then insert. Try a few things. Also ensure you are placing the files on the external SD card and not the internal one labeled as IFSD or whatever.

Edit 2: Double checked firmware and the code looks all correct.
Reply
#12
I did several tests and now I can confirm: It is definitively an issue with my SD card! The Mod worked well!

What I tested:

1. 1GB Micro SD Card in FAT format + Old SanDisk Adapter -> everything worked right away

2. 32GB Micro SD Card in FAT32 format + Old SanDisk Adapter -> Only cartridge backups worked (this is the one I used from the beginning with a new SanDisk SD/SDHC/SDXC adapter and I thought could be a problem with the adapter, but it wasn't)

3. old 4GB SD card 133x in FAT32 format -> everything worked right away

4. re-formated the 32GB card (Fat32 as I couldn't format it to FAT), copied every thing again back on the SD card, did a diskcheck/ repair, did defragmentation, used both adapters -> still only the cartrige backups work

So now I did as you said put in the 32GB SD card, tried to start Ebooks and flash games, put the dump files on the card and let the dump run.

I did the same thing with the old 4GB SD card and now I have 2 mounts.txt files. Please find them attached for your review.

It is still weird for me that I can run cartridges on the 32GB card but nothing else. Huh Undecided


Attached Files
.txt   mounts-32GB SanDisk Micro SDHC class10.txt (Size: 1.26 KB / Downloads: 241)
.txt   mounts-4GB green memory SD 133x.txt (Size: 1.26 KB / Downloads: 381)
Reply
#13
not sure why that 32GB won't remount with noexec. The reason the carts work but nothing else is the carts are in .bin format and run through a different code process which does not execute directly from the SD card but rather "mounts" the cart elsewhere and runs that.
Reply
#14
Well, don't mind. I found a way it works for me and if it's only to use another SD it's an easy fix.

Thank you for all your work!

Regards

Rainer
Reply
#15
Hi,

i have a problem with the 44.x Firmware. Flashing the hack works nice but Video playback with mpeg4 codec dont work anymore.
not with the original before and not after flash the hack. mjpeg codec works but this is a bad format double size by some bitrate and very
bad quality. i see as comment on the french hack "divx enabled mod". can anyone implent this in the de firmware too ?????????
thx for all your work.
kind regards,
bigghost
Reply
#16
Have you tried my video converter app? The newer firmware should use the h.264 codec and the video file should not be that large.

http://spiffyhacks.com/thread-117.html
Reply
#17
Sry no. I don´t use Windows.
I convert under Linux with ffmpeg and i have tried today h.264
libx264 libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 (codec h264)
and dont work Sad

but i see ffmpeg have a second typ like
libx264rgb libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 RGB (codec h264)

dont know the difference but i test it.

that mpeg4 are not working anymore is bad.
the videos with your converter works on older firmware 16.x too ???

your converter use ffmpeg too what kind of options you use ?
Reply
#18
video works now. the parameters -profile:v baseline -level 3.0 gives me a working h.264 video with libx264. thx for your help
Reply
#19
Yea I was going to mention you have to use the baseline profile for it to work. Glad you got it sorted Smile
Reply


Forum Jump: