Hello There, Guest! Register
Enjoy our site and services? You may donate to help fund server and domain costs. Donate Here for special benefits. You have donated $

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LeapPad2 now is working quite well as a retro emulator console
#11
I have flashed the firmwware and it does run retroarch properly, but I cannot ssh or scp... I seem to remember that I had that problem previously, but I cannot remember how I have solved it.
Reply
#12
To get network:

Manually set your usbnet interface's  STATIC IP to

169.254.6.2

Do not use DHCP.  Actually anything 169.254.6.X will work, just not 169.254.6.1 which is taken by the leappad itself.


When you ran remote_flash.sh, the leappad was 169.254.8.1 and your usbnet IP was 169.254.8.something_not_1 . After the flash and reboot, the leappad IP becomes 169.254.6.1. I'm not sure why mac2612 does this, but whatever....

Sometimes usbnet takes a little while to notice a connecton, at least on my Manjaro Linux system.

I'm thinking about trying to enable real sftp access (supported by linux/windows GUI file managers) instead of this dropbear crap. openssh is in the retroleap buildroot and it compiled, but I just have not gotten around to testing it out.
Reply
#13
It works now, must have been one of the issues you mentioned.

WinSCP worked pretty well under Windows 7, unfortunately, on Windows 10 I cannot get the USB Ethernet driver to be recognized, so I am stuck with Linux on VirtualBox.

How many devices do you have? I would love to try out netplay with my son (I have to Leapsters GS and one LeapPad2), but could not get it to work. I have hardcoded different IP addresses and could communicate with each of them from my PC, but they still could not see each other over my PC.
Reply
#14
I've got a couple leapsterGS devices and leappad2 devices (both revision 0x310) and a DIDJ.  I don't have kids. I bought them in a bundle a few years ago when hackaday showed pictures of Mike Wolak's work. Unfortunately, he left no documentation about how he did it so they sat in a drawer for a few years until I noticed a few weeks ago that retroleap had come along (and apparently gone away again.) There's some good info on that elinux.org site, but it is too general and disorganized to be much help.

I'm really surprised at how crappy the original OS is...Would a kid really put up with that turgid user interface? Everything is so painfully slow and impossible(?) to customize. It's so slow that at first, I thought the Leappad2 was broken somehow....

I've recompiled gmenu2x, a handful of games and dingux apps for the Leapster GS and they run really well, better than on the original dingoo (which like the "retrogame" rubbish is flimsy, overpriced, overhyped, underpowered junk). Unfortunately, the leappad2 takes some work because of the weird 480x272 screen.

You mean retroarch supports some kind of netplay? Pretty much just me and the dog over here, so I have not looked into  2 player games much, LOL.
Reply
#15
Thanks for the efforts on this. I am a bit rusty after not fiddling with this for quite some time now. I will see if I can get it running on one of my tablets
Reply
#16
Yes, theoretically it could be possible to play with some cores over the net, provided that there is a computer that links them together (which somehow beats the purpose of mobile coop gaming, if you have to lug a laptop along... although maybe something like Raspberry Pi Zero could also work).

By the way, it seems you have not used the patched version of the atari800 libretro core in your compilation... It makes it rather difficult to use it, as regular keypresses (which LeapPad2 sends) are recognized before the core controls. This should be fixed on a much lower level in libretro, but nobody seems really interested. Also, there has been a tiny patch in Retroarch that removes the 'Scan directory' entries, this seems to be missing, too.
Reply
#17
Can anyone get additional cores working? I add them to the libretro directory using scp, but selecting them in the Load Core menu does nothing and I get an 'internal error' message in retro.log?
Reply
#18
(01-02-2020, 01:35 PM)fiveww Wrote: Can anyone get additional cores working? I add them to the libretro directory using scp, but selecting them in the Load Core menu does nothing and I get an 'internal error' message in retro.log?
Were did you get your additional cores? You have to compile them using the retroleap buildroot by selecting them in the menu after you run:

make menuconfig

and then:

make

and then:
scp them from where_you_installed/retroleap/output/target/usr/lib/libretro

to /usr/lib/libretro on your leappad2.


Anyway, I've built a bunch of them. btw, they will also work on LeapsterGS, a vastly superior ~$20 game system.

The zip attached contains:

MGBA-- slower than GPSP, but runs GB/GBC games very well

NGP-- I've tested a few games and they seem to work well.

Stella-- Atari2600 my first console. Disable select key in your retroarch config for this one.

Gambatte-- GB/GBC; I have not thoroughly tested. Seems ok.

o2em--videopac; ancient "TV game" seems to work, I guess.

vectrex, fmsx, lynx,wonderswan,pce --I'm not familiar with these; didn't test.

@Jabberwok: the rootfs is the same as retroleap 1.2.1. The only changes were to the kernel (uImage) to pick the right GPIOs and configure them as inputs. I didn't change anything about the Atari800 core (or anything else). I've done a lot of testing with (sc. "played with") Gameboy, Atari2600, and NGP. I'll take a look though. Can you recommend any Atari800 game?


Attached Files
.zip   cores.zip (Size: 2.44 MB / Downloads: 21)
Reply
#19
Ahhhhhh ok, I understand, I'll do it that way instead! Wonderful, thank you.

Yes got LP2 and a LeapsterGS. Funny you mention Vectrex, the LP2 would be ideal in portrait mode for that! I'll give that a try as have fond memories of my Vectrex from yesteryear!
Reply
#20
I have made some changes to the original Atari core that were a workaround for the problem I have described. Can you check that the core you are compiling is from my github, as stated in the retroleap source, and not from the original atari core? It should be:

LIBRETRO_ATARI800_SITE = $(call github,JabberwockPL,libretro-atari800,$(LIBRETRO_ATARI800_VERSION))

If it is the same, then it must be due to the differences in keyboard handling between LeapsterGS and the latest version of LeapPad2. For example in Bruce Lee when I press A button on LeapsterGS, Bruce only punches. On LeapPad2 he punches, but also **PAUSED** flashes - it means the game detects both the joystick button and a keyboard press.
Reply


Forum Jump: