Hello There, Guest! Register
Enjoy our site and services? You may donate to help fund server and domain costs. Donate Here for special benefits. You have donated $

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[ROOT] Some more LeapFrog Epic tweaks

I know this involves root, as not all parents are up to it, but in case you feel like your son or daughter's LeapFrog isn't cutting it, I found out a few more tweaks which should add a bit more functionality and make it more usable.

As I said earlier, this requires root, which can be done using one-click utilities. The PC version of Kingoroot should do the trick. Once you root your device, you'll also have to install Xposed for the other tweaks to run.

Bring back the recent apps button
I'm sure you've noticed that the navigation bar on the Epic lacks the recent apps button for some reason. 'Tis uncertain as to why, but my hunch is that LF decided to dummy it out to keep children from opening it by accident. Fortunately, the ROM is still largely AOSP-based so it's just the matter of using Xperia/AOSP Navbar Buttons to gain back task switcher access. GravityBox for Kitkat seems like a viable option as well, though I haven't tried it myself yet.

Home sweet home
Ever grow tired of the KidLauncher? That rather infantile app drawer you or your kids are subjected to every time you play with the Epic? For a while I thought it's a matter of modding the framework files to get alternative home screens to install, but turns out it's no different from restoring SD card read-write functionality.

Assuming you've rooted your device already, mount /system as read-write using either ADB or Terminal:
mount -o rw,remount,rw /system

Once that's done, navigate to /system/etc/permissions then open tablet_core_hardware.xml using a text editor. Look for the following lines:
<!--feature name="android.software.app_widgets" /--> <!-- Not available in Narnia -->
<!--feature name="android.software.home_screen" /--> <!-- Not available in Narnia -->

...then replace the commented settings with this:
<feature name="android.software.app_widgets" />
<feature name="android.software.home_screen" />

Save your edited XML file, and then reboot. If done correctly, you should be able to install any home launcher you want. However, you'll have to freeze/disable KidLauncher and Launcher using ROM Toolbox or some other utility for your favourite launcher to work as default.

There are some caveats to using an alternative home screen though. One of them is that the navigation bar may disappear or that some of the soft keys may refuse to show up upon running certain apps (e.g. LeapFrog games). A workaround would be to open up App Manager for the missing keys to appear again. Another issue is with user profiles - as the login screen is built into KidLauncher, disabling it would render your children's profiles (and thus time restrictions and other parental controls) useless, plus rewards and other items earned may not show up (I presume this is due to the alternative home screen being counted as a different "user"). One could try using a third-party parental control panel app, but that would require another setup phase as it isn't weaved into LeapFrog's own parental controls service.
Please help me. My LeapFrog Epic does not work. After the logo, it reboots.
The tablet worked, I did everything according to the instructions, everything is super. Many thanks. But I wanted to change the restore menu, I wanted to make a copy of the system ... and everything broke ...%)
Can you give me a backup system and drivers for a PC?
Let me know how it goes with your Epic, mate, just take note of what I outlined in my email and you should be fine.
everything broke ...%)
Now it does not work at all, the screen does not light up. The computer is determined, even stitched, but everything is unchanged ... I have already tried various methods.

The second Epic demo, it turned out perfectly to establish with the help of your systems. Img, like real)), google market works. Spassibo)
Glad you got the other one to work, mate. Sorry if the other one got whacked though. I am actually trying to get my bricked Epic to work last month to no avail. It pays to make a backup of EVERYTHING first using Readback before you actually go around with flashing a new ROM. Trust me, I can attest to that.
Good job.
Im trying to get the framework installed but it keeps telling it is not yet supported so it doesn't do anything.  The app is there, i have root, but can't get the rest installed.  What version of the app should i be using?

Forum Jump: