Hello There, Guest! Register
Enjoy our site and services? You may donate to help fund server and domain costs. Donate Here for special benefits. You have donated $

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Duke Nukem 3D! on the leap TV
#11
(01-07-2016, 03:53 AM)is0-mick Wrote:  I've updated the post with the binaries Smile Let me know how you get on. Mick
Seems to work fine, thank you. Took some time as I didn't  want to replace pointer training games. Now thanks to this post http://spiffyhacks.com/thread-824-post-4...ml#pid4057 describing following command
Code:
lfpkg2 /LF/Bulk/ProgramFiles/*/meta.inf"
and after moving it to diferent folder and changing id to 0x00410035  I have Duke3d as additional launcher icon and it works :-)

I have no audio on my monitor so cannot verify timidity working but otherwise it works including controller. Sadly there are too few buttons for proper Duke3d experience. I tried to attach keyboard or mouse via usb OTG cable but it looks like there are no drivers in kernel for usb hid devices. Or at least it did not work and kernel log only had something like this when connecting/disconnecting mouse and later keyboard
Code:
Indeed it is in host mode hprt0 = 00041901

*** We think we are detecting a new host-mode attachment.  Post 1 at clear UFC_C_PORT_ENABLE
***** << dwc_otg_hcd_set_input_event (78) data=1 >>
usb 2-1: new low-speed USB device number 6 using dwc_otg
Indeed it is in host mode hprt0 = 00041901
*** We think we are detecting a new host-mode attachment.  Post 1 at clear UFC_C_PORT_ENABLE
***** << dwc_otg_hcd_set_input_event (78) data=1 >>
***** CPF << dwc_otg_hcd_hub_control (2527) >>
***** << dwc_otg_hcd_post_input_event (84) data=1 >>
Posting SW_LID=1 to linux input event USB
***** << dwc_otg_hcd_set_input_event (78) data=0 >>
***** CPF << dwc_otg_hcd_hub_control (2527) >>
***** << dwc_otg_hcd_post_input_event (84) data=0 >>
Posting SW_LID=0 to linux input event USB
usb 2-1: USB disconnect, device number 6
***** << dwc_otg_hcd_set_input_event (78) data=0 >>
Indeed it is in host mode hprt0 = 00041901
*** We think we are detecting a new host-mode attachment.  Post 1 at clear UFC_C_PORT_ENABLE
***** << dwc_otg_hcd_set_input_event (78) data=1 >>
usb 2-1: new low-speed USB device number 7 using dwc_otg
Indeed it is in host mode hprt0 = 00041901
*** We think we are detecting a new host-mode attachment.  Post 1 at clear UFC_C_PORT_ENABLE
***** << dwc_otg_hcd_set_input_event (78) data=1 >>
***** CPF << dwc_otg_hcd_hub_control (2527) >>
***** << dwc_otg_hcd_post_input_event (84) data=1 >>
Posting SW_LID=1 to linux input event USB
***** << dwc_otg_hcd_set_input_event (78) data=0 >>
***** CPF << dwc_otg_hcd_hub_control (2527) >>
***** << dwc_otg_hcd_post_input_event (84) data=0 >>
Posting SW_LID=0 to linux input event USB
usb 2-1: USB disconnect, device number 7
This was not power issue as both keyboard and mouse light went on and kernel sees new usb device but no driver gets attached to it :-(
And same with usb stick BTW, no usb-storage driver :-(
Looks like there is only camera driver for host mode and gadget mass storage device driver for dftp usb device.
Reply
#12
(01-13-2016, 02:56 PM)fanoush Wrote:
(01-07-2016, 03:53 AM)is0-mick Wrote:  I've updated the post with the binaries Smile Let me know how you get on. Mick
Seems to work fine, thank you. Took some time as I didn't  want to replace pointer training games. Now thanks to this post http://spiffyhacks.com/thread-824-post-4...ml#pid4057 describing following command

Code:
lfpkg2 /LF/Bulk/ProgramFiles/*/meta.inf"
and after moving it to diferent folder and changing id to 0x00410035  I have Duke3d as additional launcher icon and it works :-)

I have no audio on my monitor so cannot verify timidity working but otherwise it works including controller. Sadly there are too few buttons for proper Duke3d experience. I tried to attach keyboard or mouse via usb OTG cable but it looks like there are no drivers in kernel for usb hid devices. Or at least it did not work and kernel log only had something like this when connecting/disconnecting mouse and later keyboard

Code:
Indeed it is in host mode hprt0 = 00041901

*** We think we are detecting a new host-mode attachment.  Post 1 at clear UFC_C_PORT_ENABLE
***** << dwc_otg_hcd_set_input_event (78) data=1 >>
usb 2-1: new low-speed USB device number 6 using dwc_otg
Indeed it is in host mode hprt0 = 00041901
*** We think we are detecting a new host-mode attachment.  Post 1 at clear UFC_C_PORT_ENABLE
***** << dwc_otg_hcd_set_input_event (78) data=1 >>
***** CPF << dwc_otg_hcd_hub_control (2527) >>
***** << dwc_otg_hcd_post_input_event (84) data=1 >>
Posting SW_LID=1 to linux input event USB
***** << dwc_otg_hcd_set_input_event (78) data=0 >>
***** CPF << dwc_otg_hcd_hub_control (2527) >>
***** << dwc_otg_hcd_post_input_event (84) data=0 >>
Posting SW_LID=0 to linux input event USB
usb 2-1: USB disconnect, device number 6
***** << dwc_otg_hcd_set_input_event (78) data=0 >>
Indeed it is in host mode hprt0 = 00041901
*** We think we are detecting a new host-mode attachment.  Post 1 at clear UFC_C_PORT_ENABLE
***** << dwc_otg_hcd_set_input_event (78) data=1 >>
usb 2-1: new low-speed USB device number 7 using dwc_otg
Indeed it is in host mode hprt0 = 00041901
*** We think we are detecting a new host-mode attachment.  Post 1 at clear UFC_C_PORT_ENABLE
***** << dwc_otg_hcd_set_input_event (78) data=1 >>
***** CPF << dwc_otg_hcd_hub_control (2527) >>
***** << dwc_otg_hcd_post_input_event (84) data=1 >>
Posting SW_LID=1 to linux input event USB
***** << dwc_otg_hcd_set_input_event (78) data=0 >>
***** CPF << dwc_otg_hcd_hub_control (2527) >>
***** << dwc_otg_hcd_post_input_event (84) data=0 >>
Posting SW_LID=0 to linux input event USB
usb 2-1: USB disconnect, device number 7
This was not power issue as both keyboard and mouse light went on and kernel sees new usb device but no driver gets attached to it :-(
And same with usb stick BTW, no usb-storage driver :-(
Looks like there is only camera driver for host mode and gadget mass storage device driver for dftp usb device.

Yes I got a USB Hub and connected the camera which worked just fine but as soon as I connect ANYTHING else the leapTV freezes.   Keyboard dont work nor do Mice or unified receivers.  
Reply
#13
for me nothing freezes it just doesn't attach any driver, even lsusb (from buildroot busybox) prints correct vid/pid detected. Time to get leaptv kernel source from leapfrog and compile missing drivers as modules. I just sent request to support at leapfrog.com as per http://s7.leapfrog.com/is/content/LeapFr...-LeapTVpdf let's see what happens.
Reply
#14
(01-13-2016, 11:45 PM)fanoush Wrote: for me nothing freezes it just doesn't attach any driver, even lsusb (from buildroot busybox) prints correct vid/pid detected. Time to get leaptv kernel source from leapfrog and compile missing drivers as modules. I just sent request to support at leapfrog.com as per http://s7.leapfrog.com/is/content/LeapFr...-LeapTVpdf let's see what happens.

Or grab them from here:
https://mega.nz/#!pNoxUSjI!SyAS6O_UmyV-dp65DnAOQetuQoHq9x6CoebFIv6lit4

One of the guys over at OpenLF posted them the other week for us.

Mick
Reply
#15
Thanks, got it. Will try to build the kernel.


And BTW categorizing source tarballs into 58 different folders named by licence combinations (19 folders starting with GPL + additional 11 folders starting LGPL)  is simply crazy :-) 
Reply
#16
new links as requested:

SDL Libs: http://www107.zippyshare.com/v/7VnChYKT/file.html
Duke: http://www107.zippyshare.com/v/coD7zpVg/file.html
Doom: http://www107.zippyshare.com/v/YAh2zzEJ/file.html

Mick
Reply


Forum Jump: